ci: [mac] Update Xcode version to Qt 5 supported master
authorShane Synan <digitalcircuit36939@gmail.com>
Fri, 15 Oct 2021 03:32:26 +0000 (23:32 -0400)
committerManuel Nickschas <sputnick@quassel-irc.org>
Fri, 15 Oct 2021 07:16:36 +0000 (09:16 +0200)
Xcode 10.3 is no longer available.  Update to the latest version Qt 5
supports.. though 12.5.1 has not rolled out across all build images.
Use 12.4.0 for now (this can be increased later).

This fixes build failures.

See https://doc.qt.io/qt-5/macos.html

.github/workflows/main.yml

index e75905f..661e8b7 100644 (file)
@@ -97,7 +97,8 @@ jobs:
       uses: maxim-lobanov/setup-xcode@v1
       with:
         # Newer Xcode versions may not officially be supported by Qt
-        xcode-version: '10.3'
+        # Check https://doc.qt.io/qt-5/macos.html
+        xcode-version: '12.4.0'
 
     - name: Check out source code
       uses: actions/checkout@v2