Fix build error if QCA2 isn't around
[quassel.git] / src / uisupport / CMakeLists.txt
index 934e3fd..f3b7cad 100644 (file)
@@ -84,8 +84,11 @@ endif(HAVE_KDE)
 
 include_directories(${CMAKE_SOURCE_DIR}/src/common
                     ${CMAKE_SOURCE_DIR}/src/client
-                    ${QUASSEL_QT_INCLUDES}
-                    ${QCA2_INCLUDE_DIR})
+                    ${QUASSEL_QT_INCLUDES})
+
+if(HAVE_QCA2)
+  include_directories(${QCA2_INCLUDE_DIR})
+endif(HAVE_QCA2)
 
 if(NOT WITH_QT5)
   qt4_wrap_cpp(MOC ${MOC_HDRS})