Add spell-checking support via the Sonnet framework
[quassel.git] / src / uisupport / CMakeLists.txt
index 37ea311..a72a9c7 100644 (file)
@@ -60,4 +60,7 @@ endif()
 
 if (WITH_KF5)
     target_link_libraries(mod_uisupport KF5::CoreAddons KF5::TextWidgets KF5::XmlGui)
+elseif (KF5Sonnet_FOUND)
+    add_definitions(-DHAVE_SONNET)
+    target_link_libraries(mod_uisupport KF5::SonnetUi)
 endif()