test: Introduce Quassel::Test::Global library
[quassel.git] / src / test / global / CMakeLists.txt
diff --git a/src/test/global/CMakeLists.txt b/src/test/global/CMakeLists.txt
new file mode 100644 (file)
index 0000000..f3f4ed2
--- /dev/null
@@ -0,0 +1,13 @@
+quassel_add_module(Test::Global EXPORT NOINSTALL)
+
+target_sources(${TARGET} PRIVATE
+    testglobal.h
+)
+
+target_link_libraries(${TARGET}
+    PUBLIC
+        GTest::GTest
+        Qt5::Core
+        Qt5::Test
+        Quassel::Common
+)