Add SslInfoDlg as a nice way to show information about an SSL connection
[quassel.git] / src / qtui / CMakeLists.txt
index 8ec3ad2..3e7e067 100644 (file)
@@ -5,6 +5,10 @@ set(QT_USE_QTNETWORK 1)
 set(QT_USE_QTDBUS 1)
 include(${QT_USE_FILE})
 
+if(INDICATEQT_FOUND)
+  include_directories(${INDICATEQT_INCLUDE_DIRS})
+endif(INDICATEQT_FOUND)
+
 set(SOURCES
     aboutdlg.cpp
     awaylogfilter.cpp
@@ -25,7 +29,9 @@ set(SOURCES
     columnhandleitem.cpp
     coreconfigwizard.cpp
     coreconnectdlg.cpp
+    coreconnectionstatuswidget.cpp
     coreinfodlg.cpp
+    debugbufferviewoverlay.cpp
     debugconsole.cpp
     debuglogwidget.cpp
     debugmessagemodelfilter.cpp
@@ -48,7 +54,6 @@ set(SOURCES
     systraynotificationbackend.cpp
     taskbarnotificationbackend.cpp
     titlesetter.cpp
-    topiclabel.cpp
     topicwidget.cpp
     verticaldock.cpp
     webpreviewitem.cpp)
@@ -70,7 +75,9 @@ set(MOC_HDRS
     columnhandleitem.h
     coreconfigwizard.h
     coreconnectdlg.h
+    coreconnectionstatuswidget.h
     coreinfodlg.h
+    debugbufferviewoverlay.h
     debugconsole.h
     debuglogwidget.h
     debugmessagemodelfilter.h
@@ -84,6 +91,7 @@ set(MOC_HDRS
     qtui.h
     qtuiapplication.h
     qtuimessageprocessor.h
+    qtuistyle.h
     settingsdlg.h
     settingspagedlg.h
     simplenetworkeditor.h
@@ -91,7 +99,6 @@ set(MOC_HDRS
     systraynotificationbackend.h
     taskbarnotificationbackend.h
     titlesetter.h
-    topiclabel.h
     topicwidget.h
     verticaldock.h)
 
@@ -100,7 +107,6 @@ set(HEADERS
     chatlinemodelitem.h
     chatviewsettings.h
     qtuisettings.h
-    qtuistyle.h
     webpreviewitem.h)
 
 set(FORMS
@@ -109,13 +115,13 @@ set(FORMS
     bufferwidget.ui
     channellistdlg.ui
     chatviewsearchbar.ui
-    coreaccounteditdlg.ui
     coreconfigwizardintropage.ui
     coreconfigwizardadminuserpage.ui
     coreconfigwizardstorageselectionpage.ui
     coreconfigwizardsyncpage.ui
-    coreconnectdlg.ui
+    coreconnectauthdlg.ui
     coreinfodlg.ui
+    debugbufferviewoverlay.ui
     debugconsole.ui
     debuglogwidget.ui
     inputwidget.ui
@@ -145,6 +151,18 @@ else(HAVE_KDE)
   endif(HAVE_PHONON)
 endif(HAVE_KDE)
 
+if(HAVE_SSL)
+  set(SOURCES ${SOURCES} sslinfodlg.cpp)
+  set(MOC_HDRS ${MOC_HDRS} sslinfodlg.h)
+  set(FORMS ${FORMS} sslinfodlg.ui)
+endif(HAVE_SSL)
+
+if(INDICATEQT_FOUND)
+  set(SOURCES ${SOURCES} indicatornotificationbackend.cpp)
+  set(MOC_HDRS ${MOC_HDRS} indicatornotificationbackend.h)
+  set(FORMS ${FORMS} indicatornotificationconfigwidget.ui)
+endif(INDICATEQT_FOUND)
+
 foreach(FORM ${FORMS})
   set(FORMPATH ${FORMPATH} ui/${FORM})
 endforeach(FORM ${FORMS})