Add SslInfoDlg as a nice way to show information about an SSL connection
[quassel.git] / src / qtui / CMakeLists.txt
index 59d3ce8..3e7e067 100644 (file)
@@ -28,6 +28,8 @@ set(SOURCES
     chatviewsettings.cpp
     columnhandleitem.cpp
     coreconfigwizard.cpp
+    coreconnectdlg.cpp
+    coreconnectionstatuswidget.cpp
     coreinfodlg.cpp
     debugbufferviewoverlay.cpp
     debugconsole.cpp
@@ -72,6 +74,8 @@ set(MOC_HDRS
     chatviewsearchcontroller.h
     columnhandleitem.h
     coreconfigwizard.h
+    coreconnectdlg.h
+    coreconnectionstatuswidget.h
     coreinfodlg.h
     debugbufferviewoverlay.h
     debugconsole.h
@@ -115,6 +119,7 @@ set(FORMS
     coreconfigwizardadminuserpage.ui
     coreconfigwizardstorageselectionpage.ui
     coreconfigwizardsyncpage.ui
+    coreconnectauthdlg.ui
     coreinfodlg.ui
     debugbufferviewoverlay.ui
     debugconsole.ui
@@ -146,6 +151,12 @@ else(HAVE_KDE)
   endif(HAVE_PHONON)
 endif(HAVE_KDE)
 
+if(HAVE_SSL)
+  set(SOURCES ${SOURCES} sslinfodlg.cpp)
+  set(MOC_HDRS ${MOC_HDRS} sslinfodlg.h)
+  set(FORMS ${FORMS} sslinfodlg.ui)
+endif(HAVE_SSL)
+
 if(INDICATEQT_FOUND)
   set(SOURCES ${SOURCES} indicatornotificationbackend.cpp)
   set(MOC_HDRS ${MOC_HDRS} indicatornotificationbackend.h)