Add SslInfoDlg as a nice way to show information about an SSL connection
[quassel.git] / src / qtui / CMakeLists.txt
index 28e1b68..3e7e067 100644 (file)
@@ -151,6 +151,12 @@ else(HAVE_KDE)
   endif(HAVE_PHONON)
 endif(HAVE_KDE)
 
   endif(HAVE_PHONON)
 endif(HAVE_KDE)
 
+if(HAVE_SSL)
+  set(SOURCES ${SOURCES} sslinfodlg.cpp)
+  set(MOC_HDRS ${MOC_HDRS} sslinfodlg.h)
+  set(FORMS ${FORMS} sslinfodlg.ui)
+endif(HAVE_SSL)
+
 if(INDICATEQT_FOUND)
   set(SOURCES ${SOURCES} indicatornotificationbackend.cpp)
   set(MOC_HDRS ${MOC_HDRS} indicatornotificationbackend.h)
 if(INDICATEQT_FOUND)
   set(SOURCES ${SOURCES} indicatornotificationbackend.cpp)
   set(MOC_HDRS ${MOC_HDRS} indicatornotificationbackend.h)