Introduce netsplit detection/handling
[quassel.git] / src / core / CMakeLists.txt
index 8198773..d5624d6 100644 (file)
@@ -11,18 +11,24 @@ set(SOURCES
     basichandler.cpp
     core.cpp
     corealiasmanager.cpp
+    coreapplication.cpp
     corebacklogmanager.cpp
+    corebuffersyncer.cpp
     corebufferviewconfig.cpp
     corebufferviewmanager.cpp
     corecoreinfo.cpp
+    coreidentity.cpp
+    coreircchannel.cpp
     coreirclisthelper.cpp
     corenetwork.cpp
+    corenetworkconfig.cpp
     coresession.cpp
     coresettings.cpp
     coreusersettings.cpp
     ctcphandler.cpp
     ircserverhandler.cpp
-    networkconnection.cpp
+    netsplit.cpp
+    postgresqlstorage.cpp
     sessionthread.cpp
     sqlitestorage.cpp
     storage.cpp
@@ -33,16 +39,22 @@ set(MOC_HDRS
     basichandler.h
     core.h
     corealiasmanager.h
+    coreapplication.h
     corebacklogmanager.h
+    corebuffersyncer.h
     corebufferviewconfig.h
     corebufferviewmanager.h
     corecoreinfo.h
+    coreidentity.h
+    coreircchannel.h
     coreirclisthelper.h
     corenetwork.h
+    corenetworkconfig.h
     coresession.h
     ctcphandler.h
     ircserverhandler.h
-    networkconnection.h
+    netsplit.h
+    postgresqlstorage.h
     sqlitestorage.h
     storage.h
     sessionthread.h
@@ -58,7 +70,8 @@ if(HAVE_SSL)
   include_directories(${OPENSSL_INCLUDE_DIR})
 endif(HAVE_SSL)
 
-QT4_WRAP_CPP(MOC ${MOC_HDRS})
+qt4_wrap_cpp(MOC ${MOC_HDRS})
+set(CORE_RCS ${CORE_RCS} core/sql.qrc PARENT_SCOPE)
 
 include_directories(${CMAKE_SOURCE_DIR}/src/common)