Finally sanitizificat0red the mess and #ifdef hell with main.cpp, Global:: and friends
[quassel.git] / src / core / CMakeLists.txt
index d73be7c..c69ec2a 100644 (file)
@@ -11,6 +11,7 @@ set(SOURCES
     basichandler.cpp
     core.cpp
     corealiasmanager.cpp
+    coreapplication.cpp
     corebacklogmanager.cpp
     corebufferviewconfig.cpp
     corebufferviewmanager.cpp
@@ -33,6 +34,7 @@ set(MOC_HDRS
     basichandler.h
     core.h
     corealiasmanager.h
+    coreapplication.h
     corebacklogmanager.h
     corebufferviewconfig.h
     corebufferviewmanager.h
@@ -52,11 +54,11 @@ set(HEADERS
     coresettings.h
     coreusersettings.h)
 
-if(OPENSSL_FOUND AND NOT QT_DEFINITIONS MATCHES "QT_NO_OPENSSL")
+if(HAVE_SSL)
   set(SOURCES ${SOURCES} sslserver.cpp)
   set(MOC_HDRS ${MOC_HDRS} sslserver.h)
   include_directories(${OPENSSL_INCLUDE_DIR})
-endif(OPENSSL_FOUND AND NOT QT_DEFINITIONS MATCHES "QT_NO_OPENSSL")
+endif(HAVE_SSL)
 
 QT4_WRAP_CPP(MOC ${MOC_HDRS})