Merge pull request #89 from mamarley/ssloidentdfix
[quassel.git] / src / core / CMakeLists.txt
index cd29875..6a0611a 100644 (file)
@@ -12,7 +12,6 @@ set(SOURCES
     corebufferviewconfig.cpp
     corebufferviewmanager.cpp
     corecoreinfo.cpp
-    coreeventmanager.cpp
     coreidentity.cpp
     coreignorelistmanager.cpp
     coreircchannel.cpp
@@ -57,7 +56,8 @@ endif()
 
 include_directories(${CMAKE_SOURCE_DIR}/src/common)
 
-set(CORE_RCS ${CORE_RCS} core/sql.qrc PARENT_SCOPE)
+set(CORE_RCS ${CORE_RCS} ${CMAKE_CURRENT_SOURCE_DIR}/sql.qrc)
+qt_add_resources(SOURCES ${CORE_RCS})
 
 add_library(mod_core STATIC ${SOURCES})
 qt_use_modules(mod_core Core Network Script Sql)