this should tackle sqlites issues with concurrent access
[quassel.git] / src / core / CMakeLists.txt
index 1400710..4491f56 100644 (file)
@@ -10,9 +10,13 @@ set(SOURCES
     abstractsqlstorage.cpp
     basichandler.cpp
     core.cpp
+    corealiasmanager.cpp
+    coreapplication.cpp
     corebacklogmanager.cpp
     corebufferviewconfig.cpp
     corebufferviewmanager.cpp
+    corecoreinfo.cpp
+    coreircchannel.cpp
     coreirclisthelper.cpp
     corenetwork.cpp
     coresession.cpp
@@ -30,9 +34,13 @@ set(MOC_HDRS
     abstractsqlstorage.h
     basichandler.h
     core.h
+    corealiasmanager.h
+    coreapplication.h
     corebacklogmanager.h
     corebufferviewconfig.h
     corebufferviewmanager.h
+    corecoreinfo.h
+    coreircchannel.h
     coreirclisthelper.h
     corenetwork.h
     coresession.h
@@ -48,18 +56,16 @@ set(HEADERS
     coresettings.h
     coreusersettings.h)
 
-# QT_DEFINITIONS actually does not work, stuff gets included always.
-# Funny enough that does not seem to be harmful, but we should still find a way to figure out
-# if we have openssl in Qt...
-if(OPENSSL_FOUND AND NOT QT_DEFINITIONS MATCHES "-DQT_NO_OPENSSL")
+if(HAVE_SSL)
   set(SOURCES ${SOURCES} sslserver.cpp)
   set(MOC_HDRS ${MOC_HDRS} sslserver.h)
   include_directories(${OPENSSL_INCLUDE_DIR})
-endif(OPENSSL_FOUND AND NOT QT_DEFINITIONS MATCHES "-DQT_NO_OPENSSL")
+endif(HAVE_SSL)
 
-QT4_WRAP_CPP(MOC ${MOC_HDRS})
+qt4_wrap_cpp(MOC ${MOC_HDRS})
+qt4_add_resources(RC_SQL sql.qrc)
 
 include_directories(${CMAKE_SOURCE_DIR}/src/common)
 
-add_library(mod_core STATIC ${SOURCES} ${MOC} ${HEADERS})
+add_library(mod_core STATIC ${SOURCES} ${MOC} ${HEADERS} ${RC_SQL})
 add_dependencies(mod_core mod_common)