Abstract away the protocol handshake code
[quassel.git] / src / core / CMakeLists.txt
index 5c6f0b6..42dac8f 100644 (file)
@@ -7,6 +7,7 @@ set(SOURCES
     core.cpp
     corealiasmanager.cpp
     coreapplication.cpp
+    coreauthhandler.cpp
     corebacklogmanager.cpp
     corebasichandler.cpp
     corebuffersyncer.cpp
@@ -40,12 +41,14 @@ set(MOC_HDRS
     core.h
     corealiasmanager.h
     coreapplication.h
+    coreauthhandler.h
     corebacklogmanager.h
     corebasichandler.h
     corebuffersyncer.h
     corebufferviewconfig.h
     corebufferviewmanager.h
     corecoreinfo.h
+    coreeventmanager.h
     coreidentity.h
     coreignorelistmanager.h
     coreircchannel.h