Use the provided CMake variables rather than hardcoding names for the SSL libs
[quassel.git] / src / core / CMakeLists.txt
index 294fb4c..37110f3 100644 (file)
@@ -50,6 +50,8 @@ set(HEADERS
 if(OPENSSL_FOUND AND NOT QT_DEFINITIONS MATCHES "-DQT_NO_OPENSSL")
   set(SOURCES ${SOURCES} sslserver.cpp)
   set(MOC_HDRS ${MOC_HDRS} sslserver.h)
+  link_libraries(${OPENSSL_LIBRARIES})
+  include_directories(${OPENSSL_INCLUDE_DIR})
 endif(OPENSSL_FOUND AND NOT QT_DEFINITIONS MATCHES "-DQT_NO_OPENSSL")
 
 QT4_WRAP_CPP(MOC ${MOC_HDRS})