Rename Internal-, Remote- and LegacyConnection to -Peer
[quassel.git] / src / common / CMakeLists.txt
index 2ddd926..fe1d4f9 100644 (file)
@@ -17,6 +17,7 @@ set(SOURCES
     eventmanager.cpp
     identity.cpp
     ignorelistmanager.cpp
     eventmanager.cpp
     identity.cpp
     ignorelistmanager.cpp
+    internalpeer.cpp
     ircchannel.cpp
     ircevent.cpp
     irclisthelper.cpp
     ircchannel.cpp
     ircevent.cpp
     irclisthelper.cpp
@@ -28,10 +29,14 @@ set(SOURCES
     networkconfig.cpp
     networkevent.cpp
     quassel.cpp
     networkconfig.cpp
     networkevent.cpp
     quassel.cpp
+    remotepeer.cpp
     settings.cpp
     signalproxy.cpp
     syncableobject.cpp
     settings.cpp
     signalproxy.cpp
     syncableobject.cpp
-    util.cpp)
+    util.cpp
+
+    protocols/legacy/legacypeer.cpp
+)
 
 set(MOC_HDRS
     aliasmanager.h
 
 set(MOC_HDRS
     aliasmanager.h
@@ -44,14 +49,19 @@ set(MOC_HDRS
     eventmanager.h
     identity.h
     ignorelistmanager.h
     eventmanager.h
     identity.h
     ignorelistmanager.h
+    internalpeer.h
     ircchannel.h
     irclisthelper.h
     ircuser.h
     network.h
     networkconfig.h
     ircchannel.h
     irclisthelper.h
     ircuser.h
     network.h
     networkconfig.h
+    remotepeer.h
     settings.h
     signalproxy.h
     settings.h
     signalproxy.h
-    syncableobject.h)
+    syncableobject.h
+
+    protocols/legacy/legacypeer.h
+)
 
 set(HEADERS ${MOC_HDRS}
     abstractcliparser.h
 
 set(HEADERS ${MOC_HDRS}
     abstractcliparser.h
@@ -64,6 +74,7 @@ set(HEADERS ${MOC_HDRS}
     networkevent.h
     logger.h
     message.h
     networkevent.h
     logger.h
     message.h
+    protocol.h
     types.h
     util.h)
 
     types.h
     util.h)