cmake: Add missing Boost dependency
[quassel.git] / src / common / CMakeLists.txt
index ebc626f..f53988d 100644 (file)
@@ -1,4 +1,4 @@
-quassel_add_module(Common)
+quassel_add_module(Common EXPORT)
 
 target_sources(${TARGET} PRIVATE
     abstractsignalwatcher.h
@@ -17,7 +17,7 @@ target_sources(${TARGET} PRIVATE
     event.cpp
     eventmanager.cpp
     expressionmatch.cpp
-    # expressionmatchtests.cpp
+    funchelpers.h
     highlightrulemanager.cpp
     identity.cpp
     ignorelistmanager.cpp
@@ -27,7 +27,6 @@ target_sources(${TARGET} PRIVATE
     irclisthelper.cpp
     ircuser.cpp
     logger.cpp
-    logmessage.cpp
     message.cpp
     messageevent.cpp
     network.cpp
@@ -56,8 +55,6 @@ target_sources(${TARGET} PRIVATE
     # needed for automoc
     irccap.h
     protocol.h
-
-    ${COMMON_RCS}
 )
 
 # Needed for finding the generated version.h
@@ -65,11 +62,16 @@ target_include_directories(${TARGET} PRIVATE ${CMAKE_BINARY_DIR})
 
 target_link_libraries(${TARGET} PUBLIC
     ${CMAKE_DL_LIBS}
+    Boost::boost
     Qt5::Core
     Qt5::Network
     ZLIB::ZLIB
 )
 
+if (EMBED_DATA)
+    set_property(SOURCE quassel.cpp APPEND PROPERTY COMPILE_DEFINITIONS EMBED_DATA)
+endif()
+
 if (HAVE_SYSLOG)
     target_compile_definitions(${TARGET} PRIVATE -DHAVE_SYSLOG)
 endif()
@@ -91,6 +93,4 @@ if (APPLE)
     target_link_libraries(${TARGET} PUBLIC "-framework CoreServices" "-framework CoreFoundation")
 endif()
 
-# This is needed so translations are generated before trying to build the qrc.
-# Should probably find a nicer solution with proper dependencies between the involved files, though...
-add_dependencies(${TARGET} po)
+target_link_if_exists(${TARGET} PUBLIC Quassel::Resource::I18n)