included qca2 into build system
[quassel.git] / src / common / CMakeLists.txt
index 9d0af6e..e5a5e41 100644 (file)
@@ -1,4 +1,7 @@
 # Builds the common module
+if (QCA2_FOUND)
+    include_directories(${QCA2_INCLUDE_DIR})
+endif (QCA2_FOUND)
 
 set(QT_DONT_USE_QTGUI 1)
 set(QT_USE_QTNETWORK 1)
@@ -7,6 +10,7 @@ include(${QT_USE_FILE})
 set(SOURCES
     aliasmanager.cpp
     backlogmanager.cpp
+    basichandler.cpp
     bufferinfo.cpp
     buffersyncer.cpp
     bufferviewconfig.cpp
@@ -37,6 +41,7 @@ endif(CMAKE_HOST_UNIX)
 set(MOC_HDRS
     aliasmanager.h
     backlogmanager.h
+    basichandler.h
     buffersyncer.h
     bufferviewconfig.h
     bufferviewmanager.h
@@ -77,11 +82,13 @@ if(APPLE)
   target_link_libraries(mod_common "-framework CoreServices" "-framework CoreFoundation")
 endif(APPLE)
 
-if(CMAKE_HOST_UNIX)
-    find_library(libdl dl)
-    if (libdl-NOTFOUND)
-        message(FATAL_ERROR "Cannot find required library: libdl")
-    endif (libdl-NOTFOUND)
+if (QCA2_FOUND)
+  target_link_libraries(mod_common ${QCA2_LIBRARIES})
+endif (QCA2_FOUND)
 
+if(CMAKE_HOST_SYSTEM_NAME STREQUAL "Linux")
+  find_library(libdl dl)
+  if(NOT libdl MATCHES "NOTFOUND")
     target_link_libraries(mod_common ${libdl})
-endif(CMAKE_HOST_UNIX)
+  endif(NOT libdl MATCHES "NOTFOUND")
+endif(CMAKE_HOST_SYSTEM_NAME STREQUAL "Linux")