included qca2 into build system
[quassel.git] / src / common / CMakeLists.txt
index 819077a..e5a5e41 100644 (file)
@@ -1,4 +1,7 @@
 # Builds the common module
+if (QCA2_FOUND)
+    include_directories(${QCA2_INCLUDE_DIR})
+endif (QCA2_FOUND)
 
 set(QT_DONT_USE_QTGUI 1)
 set(QT_USE_QTNETWORK 1)
@@ -7,12 +10,14 @@ include(${QT_USE_FILE})
 set(SOURCES
     aliasmanager.cpp
     backlogmanager.cpp
+    basichandler.cpp
     bufferinfo.cpp
     buffersyncer.cpp
     bufferviewconfig.cpp
     bufferviewmanager.cpp
     cliparser.cpp
     identity.cpp
+    ignorelistmanager.cpp
     ircchannel.cpp
     irclisthelper.cpp
     ircuser.cpp
@@ -36,11 +41,13 @@ endif(CMAKE_HOST_UNIX)
 set(MOC_HDRS
     aliasmanager.h
     backlogmanager.h
+    basichandler.h
     buffersyncer.h
     bufferviewconfig.h
     bufferviewmanager.h
     coreinfo.h
     identity.h
+    ignorelistmanager.h
     ircchannel.h
     irclisthelper.h
     ircuser.h
@@ -70,6 +77,18 @@ include_directories(${CMAKE_CURRENT_BINARY_DIR} ${CMAKE_SOURCE_DIR})  # for vers
 set_directory_properties(PROPERTIES ADDITIONAL_MAKE_CLEAN_FILES version.gen)
 
 add_library(mod_common STATIC ${SOURCES} ${MOC})
+
 if(APPLE)
   target_link_libraries(mod_common "-framework CoreServices" "-framework CoreFoundation")
-endif(APPLE)
\ No newline at end of file
+endif(APPLE)
+
+if (QCA2_FOUND)
+  target_link_libraries(mod_common ${QCA2_LIBRARIES})
+endif (QCA2_FOUND)
+
+if(CMAKE_HOST_SYSTEM_NAME STREQUAL "Linux")
+  find_library(libdl dl)
+  if(NOT libdl MATCHES "NOTFOUND")
+    target_link_libraries(mod_common ${libdl})
+  endif(NOT libdl MATCHES "NOTFOUND")
+endif(CMAKE_HOST_SYSTEM_NAME STREQUAL "Linux")