Merge pull request #5 from Tucos/feat-keyx
[quassel.git] / src / common / CMakeLists.txt
index 7bdf1c5..c247eb3 100644 (file)
@@ -17,7 +17,7 @@ set(SOURCES
     eventmanager.cpp
     identity.cpp
     ignorelistmanager.cpp
-    internalconnection.cpp
+    internalpeer.cpp
     ircchannel.cpp
     ircevent.cpp
     irclisthelper.cpp
@@ -29,13 +29,13 @@ set(SOURCES
     networkconfig.cpp
     networkevent.cpp
     quassel.cpp
-    remoteconnection.cpp
+    remotepeer.cpp
     settings.cpp
     signalproxy.cpp
     syncableobject.cpp
     util.cpp
 
-    protocols/legacy/legacyconnection.cpp
+    protocols/legacy/legacypeer.cpp
 )
 
 set(MOC_HDRS
@@ -49,18 +49,18 @@ set(MOC_HDRS
     eventmanager.h
     identity.h
     ignorelistmanager.h
-    internalconnection.h
+    internalpeer.h
     ircchannel.h
     irclisthelper.h
     ircuser.h
     network.h
     networkconfig.h
-    remoteconnection.h
+    remotepeer.h
     settings.h
     signalproxy.h
     syncableobject.h
 
-    protocols/legacy/legacyconnection.h
+    protocols/legacy/legacypeer.h
 )
 
 set(HEADERS ${MOC_HDRS}
@@ -74,6 +74,7 @@ set(HEADERS ${MOC_HDRS}
     networkevent.h
     logger.h
     message.h
+    protocol.h
     types.h
     util.h)