Implement custom deserializer to add our own sanity checks
[quassel.git] / src / common / CMakeLists.txt
index b2aa200..b5efb4a 100644 (file)
@@ -11,8 +11,10 @@ set(SOURCES
     bufferviewmanager.cpp
     compressor.cpp
     ctcpevent.cpp
+    dccconfig.cpp
     event.cpp
     eventmanager.cpp
+    highlightrulemanager.cpp
     identity.cpp
     ignorelistmanager.cpp
     internalpeer.cpp
@@ -38,12 +40,15 @@ set(SOURCES
     transfermanager.cpp
     util.cpp
 
+    serializers/serializers.cpp
+
     protocols/datastream/datastreampeer.cpp
     protocols/legacy/legacypeer.cpp
 
     # needed for automoc
     coreinfo.h
     irccap.h
+    protocol.h
 )
 
 if (USE_QT5)
@@ -73,7 +78,7 @@ endif()
 
 if (APPLE)
     set(SOURCES ${SOURCES} mac_utils.cpp)
-endif(APPLE)
+endif()
 
 if (WIN32)
     set(SOURCES ${SOURCES} logbacktrace_win.cpp)
@@ -92,7 +97,7 @@ qt_use_modules(mod_common Core Network)
 
 if (APPLE)
     target_link_libraries(mod_common "-framework CoreServices" "-framework CoreFoundation")
-endif(APPLE)
+endif()
 
 target_link_libraries(mod_common ${CMAKE_DL_LIBS} ${EXECINFO_LIBRARIES})