Introducing the first shiny stuff for our new event-based core backend
[quassel.git] / src / common / CMakeLists.txt
index 9298b77..b27a2f1 100644 (file)
@@ -12,6 +12,8 @@ set(SOURCES
     bufferviewconfig.cpp
     bufferviewmanager.cpp
     cliparser.cpp
+    event.cpp
+    eventmanager.cpp
     identity.cpp
     ignorelistmanager.cpp
     ircchannel.cpp
@@ -35,6 +37,7 @@ set(MOC_HDRS
     bufferviewconfig.h
     bufferviewmanager.h
     coreinfo.h
+    eventmanager.h
     identity.h
     ignorelistmanager.h
     ircchannel.h
@@ -50,6 +53,7 @@ set(HEADERS ${MOC_HDRS}
     abstractcliparser.h
     bufferinfo.h
     cliparser.h
+    event.h
     logger.h
     message.h
     types.h