Output the chosen protocol type on connect
[quassel.git] / src / common / CMakeLists.txt
index ae7bfbe..9eeb91c 100644 (file)
@@ -30,6 +30,7 @@ set(SOURCES
     networkconfig.cpp
     networkevent.cpp
     peer.cpp
+    peerfactory.cpp
     quassel.cpp
     remotepeer.cpp
     settings.cpp
@@ -39,6 +40,7 @@ set(SOURCES
     transfermanager.cpp
     util.cpp
 
+    protocols/datastream/datastreampeer.cpp
     protocols/legacy/legacypeer.cpp
 )
 
@@ -61,6 +63,7 @@ set(MOC_HDRS
     network.h
     networkconfig.h
     peer.h
+    peerfactory.h
     remotepeer.h
     settings.h
     signalproxy.h
@@ -68,6 +71,7 @@ set(MOC_HDRS
     transfer.h
     transfermanager.h
 
+    protocols/datastream/datastreampeer.h
     protocols/legacy/legacypeer.h
 )