Output the chosen protocol type on connect
[quassel.git] / src / common / CMakeLists.txt
index 04fbe3b..9eeb91c 100644 (file)
@@ -30,13 +30,17 @@ set(SOURCES
     networkconfig.cpp
     networkevent.cpp
     peer.cpp
+    peerfactory.cpp
     quassel.cpp
     remotepeer.cpp
     settings.cpp
     signalproxy.cpp
     syncableobject.cpp
+    transfer.cpp
+    transfermanager.cpp
     util.cpp
 
+    protocols/datastream/datastreampeer.cpp
     protocols/legacy/legacypeer.cpp
 )
 
@@ -59,11 +63,15 @@ set(MOC_HDRS
     network.h
     networkconfig.h
     peer.h
+    peerfactory.h
     remotepeer.h
     settings.h
     signalproxy.h
     syncableobject.h
+    transfer.h
+    transfermanager.h
 
+    protocols/datastream/datastreampeer.h
     protocols/legacy/legacypeer.h
 )