silence some warnings
[quassel.git] / src / common / CMakeLists.txt
index d45a4ad..87a08d2 100644 (file)
@@ -12,6 +12,7 @@ set(SOURCES
     bufferviewconfig.cpp
     bufferviewmanager.cpp
     cliparser.cpp
+    compressor.cpp
     coreinfo.cpp
     ctcpevent.cpp
     event.cpp
@@ -40,6 +41,7 @@ set(SOURCES
     transfermanager.cpp
     util.cpp
 
+    protocols/datastream/datastreampeer.cpp
     protocols/legacy/legacypeer.cpp
 )
 
@@ -51,6 +53,7 @@ set(MOC_HDRS
     buffersyncer.h
     bufferviewconfig.h
     bufferviewmanager.h
+    compressor.h
     coreinfo.h
     eventmanager.h
     identity.h
@@ -62,7 +65,6 @@ set(MOC_HDRS
     network.h
     networkconfig.h
     peer.h
-    peerfactory.h
     remotepeer.h
     settings.h
     signalproxy.h
@@ -70,6 +72,7 @@ set(MOC_HDRS
     transfer.h
     transfermanager.h
 
+    protocols/datastream/datastreampeer.h
     protocols/legacy/legacypeer.h
 )
 
@@ -84,6 +87,7 @@ set(HEADERS ${MOC_HDRS}
     networkevent.h
     logger.h
     message.h
+    peerfactory.h
     protocol.h
     types.h
     util.h)
@@ -93,6 +97,10 @@ if (HAVE_QCA2)
     set(HEADERS ${HEADERS} keyevent.h)
 endif(HAVE_QCA2)
 
+if(NOT HAVE_ZLIB)
+    set(SOURCES ${SOURCES} ../../3rdparty/miniz/miniz.c)
+endif(NOT HAVE_ZLIB)
+
 if(APPLE)
   set(SOURCES ${SOURCES} mac_utils.cpp)
   set(HEADERS ${HEADERS} mac_utils.h)