Use system zlib if available
[quassel.git] / src / common / CMakeLists.txt
index 04fbe3b..87a08d2 100644 (file)
@@ -12,6 +12,7 @@ set(SOURCES
     bufferviewconfig.cpp
     bufferviewmanager.cpp
     cliparser.cpp
+    compressor.cpp
     coreinfo.cpp
     ctcpevent.cpp
     event.cpp
@@ -30,13 +31,17 @@ set(SOURCES
     networkconfig.cpp
     networkevent.cpp
     peer.cpp
+    peerfactory.cpp
     quassel.cpp
     remotepeer.cpp
     settings.cpp
     signalproxy.cpp
     syncableobject.cpp
+    transfer.cpp
+    transfermanager.cpp
     util.cpp
 
+    protocols/datastream/datastreampeer.cpp
     protocols/legacy/legacypeer.cpp
 )
 
@@ -48,6 +53,7 @@ set(MOC_HDRS
     buffersyncer.h
     bufferviewconfig.h
     bufferviewmanager.h
+    compressor.h
     coreinfo.h
     eventmanager.h
     identity.h
@@ -63,7 +69,10 @@ set(MOC_HDRS
     settings.h
     signalproxy.h
     syncableobject.h
+    transfer.h
+    transfermanager.h
 
+    protocols/datastream/datastreampeer.h
     protocols/legacy/legacypeer.h
 )
 
@@ -78,6 +87,7 @@ set(HEADERS ${MOC_HDRS}
     networkevent.h
     logger.h
     message.h
+    peerfactory.h
     protocol.h
     types.h
     util.h)
@@ -87,6 +97,10 @@ if (HAVE_QCA2)
     set(HEADERS ${HEADERS} keyevent.h)
 endif(HAVE_QCA2)
 
+if(NOT HAVE_ZLIB)
+    set(SOURCES ${SOURCES} ../../3rdparty/miniz/miniz.c)
+endif(NOT HAVE_ZLIB)
+
 if(APPLE)
   set(SOURCES ${SOURCES} mac_utils.cpp)
   set(HEADERS ${HEADERS} mac_utils.h)