Introduce possibility to use syslog.
[quassel.git] / src / common / CMakeLists.txt
index e79337a..710cfbc 100644 (file)
@@ -12,9 +12,9 @@ set(SOURCES
     bufferviewconfig.cpp
     bufferviewmanager.cpp
     cliparser.cpp
+    ctcpevent.cpp
     event.cpp
     eventmanager.cpp
-    eventstringifier.cpp
     identity.cpp
     ignorelistmanager.cpp
     ircchannel.cpp
@@ -42,7 +42,6 @@ set(MOC_HDRS
     bufferviewmanager.h
     coreinfo.h
     eventmanager.h
-    eventstringifier.h
     identity.h
     ignorelistmanager.h
     ircchannel.h
@@ -58,6 +57,7 @@ set(HEADERS ${MOC_HDRS}
     abstractcliparser.h
     bufferinfo.h
     cliparser.h
+    ctcpevent.h
     event.h
     ircevent.h
     networkevent.h
@@ -91,8 +91,15 @@ if(APPLE)
 endif(APPLE)
 
 if(CMAKE_HOST_SYSTEM_NAME STREQUAL "Linux")
+  set(FIND_LIBDL TRUE)
+endif(CMAKE_HOST_SYSTEM_NAME STREQUAL "Linux")
+if(CMAKE_HOST_SYSTEM_NAME STREQUAL "kFreeBSD")
+  set(FIND_LIBDL TRUE)
+endif(CMAKE_HOST_SYSTEM_NAME STREQUAL "kFreeBSD")
+
+if(FIND_LIBDL)
   find_library(libdl dl)
   if(NOT libdl MATCHES "NOTFOUND")
     target_link_libraries(mod_common ${libdl})
   endif(NOT libdl MATCHES "NOTFOUND")
-endif(CMAKE_HOST_SYSTEM_NAME STREQUAL "Linux")
+endif(FIND_LIBDL)