Don't actually build miniz if we have zlib
[quassel.git] / src / common / CMakeLists.txt
index 7807157..6a44218 100644 (file)
@@ -1,58 +1,75 @@
 # Builds the common module
 
-set(QT_DONT_USE_QTGUI 1)
-set(QT_USE_QTNETWORK 1)
-include(${QT_USE_FILE})
-
 set(SOURCES
     aliasmanager.cpp
+    authhandler.cpp
     backlogmanager.cpp
+    basichandler.cpp
     bufferinfo.cpp
     buffersyncer.cpp
     bufferviewconfig.cpp
     bufferviewmanager.cpp
-    global.cpp
+    cliparser.cpp
+    compressor.cpp
+    ctcpevent.cpp
+    event.cpp
+    eventmanager.cpp
     identity.cpp
+    ignorelistmanager.cpp
+    internalpeer.cpp
+    ircchannel.cpp
+    ircevent.cpp
+    irclisthelper.cpp
+    ircuser.cpp
     logger.cpp
     message.cpp
+    messageevent.cpp
+    network.cpp
+    networkconfig.cpp
+    networkevent.cpp
+    peer.cpp
+    peerfactory.cpp
+    quassel.cpp
+    remotepeer.cpp
     settings.cpp
     signalproxy.cpp
     syncableobject.cpp
+    transfer.cpp
+    transfermanager.cpp
     util.cpp
-    network.cpp
-    ircuser.cpp
-    ircchannel.cpp
-    cliparser.cpp)
-
-set(MOC_HDRS
-    aliasmanager.h
-    backlogmanager.h
-    buffersyncer.h
-    bufferviewconfig.h
-    bufferviewmanager.h
+
+    protocols/datastream/datastreampeer.cpp
+    protocols/legacy/legacypeer.cpp
+
+    # needed for automoc
     coreinfo.h
-    identity.h
-    ircchannel.h
-    irclisthelper.h
-    ircuser.h
-    network.h
-    settings.h
-    signalproxy.h
-    syncableobject.h)
-
-set(HEADERS ${MOC_HDRS}
-    bufferinfo.h
-    global.h
-    logger.h
-    message.h
-    types.h
-    util.h
-    cliparser.h)
-
-qt4_wrap_cpp(MOC ${MOC_HDRS})
-
-include_directories(${CMAKE_CURRENT_BINARY_DIR} ${CMAKE_SOURCE_DIR})  # for version.inc and version.gen
-add_definitions(-DHAVE_VERSION_GEN)  # we ensure that by deps in the main CMakeLists.txt
-set_directory_properties(PROPERTIES ADDITIONAL_MAKE_CLEAN_FILES version.gen)
-
-add_library(mod_common STATIC ${SOURCES} ${MOC})
+)
+
+
+if (HAVE_QCA2)
+    set(SOURCES ${SOURCES} keyevent.cpp)
+endif(HAVE_QCA2)
+
+if (NOT ZLIB_FOUND)
+    set(SOURCES ${SOURCES} ../../3rdparty/miniz/miniz.c)
+endif()
+
+if(APPLE)
+  set(SOURCES ${SOURCES} mac_utils.cpp)
+endif(APPLE)
+
+if(CMAKE_HOST_WIN32)
+    set(SOURCES ${SOURCES} logbacktrace_win.cpp)
+endif(CMAKE_HOST_WIN32)
+if(CMAKE_HOST_UNIX)
+    set(SOURCES ${SOURCES} logbacktrace_unix.cpp)
+endif(CMAKE_HOST_UNIX)
+
+add_library(mod_common STATIC ${SOURCES})
+qt_use_modules(mod_common Core Network)
+
+if(APPLE)
+  target_link_libraries(mod_common "-framework CoreServices" "-framework CoreFoundation")
+endif(APPLE)
+
+target_link_libraries(mod_common ${CMAKE_DL_LIBS})