Don't actually build miniz if we have zlib
[quassel.git] / src / common / CMakeLists.txt
index 70c0a55..6a44218 100644 (file)
@@ -1,7 +1,5 @@
 # Builds the common module
 
-setup_qt_variables(Core Network)
-
 set(SOURCES
     aliasmanager.cpp
     authhandler.cpp
@@ -13,7 +11,6 @@ set(SOURCES
     bufferviewmanager.cpp
     cliparser.cpp
     compressor.cpp
-    coreinfo.cpp
     ctcpevent.cpp
     event.cpp
     eventmanager.cpp
@@ -44,64 +41,21 @@ set(SOURCES
     protocols/datastream/datastreampeer.cpp
     protocols/legacy/legacypeer.cpp
 
-    ../../3rdparty/miniz/miniz.c
-)
-
-set(MOC_HDRS
-    aliasmanager.h
-    authhandler.h
-    backlogmanager.h
-    basichandler.h
-    buffersyncer.h
-    bufferviewconfig.h
-    bufferviewmanager.h
-    compressor.h
+    # needed for automoc
     coreinfo.h
-    eventmanager.h
-    identity.h
-    ignorelistmanager.h
-    internalpeer.h
-    ircchannel.h
-    irclisthelper.h
-    ircuser.h
-    network.h
-    networkconfig.h
-    peer.h
-    remotepeer.h
-    settings.h
-    signalproxy.h
-    syncableobject.h
-    transfer.h
-    transfermanager.h
-
-    protocols/datastream/datastreampeer.h
-    protocols/legacy/legacypeer.h
 )
 
-set(HEADERS ${MOC_HDRS}
-    abstractcliparser.h
-    bufferinfo.h
-    cliparser.h
-    ctcpevent.h
-    event.h
-    ircevent.h
-    messageevent.h
-    networkevent.h
-    logger.h
-    message.h
-    peerfactory.h
-    protocol.h
-    types.h
-    util.h)
 
 if (HAVE_QCA2)
     set(SOURCES ${SOURCES} keyevent.cpp)
-    set(HEADERS ${HEADERS} keyevent.h)
 endif(HAVE_QCA2)
 
+if (NOT ZLIB_FOUND)
+    set(SOURCES ${SOURCES} ../../3rdparty/miniz/miniz.c)
+endif()
+
 if(APPLE)
   set(SOURCES ${SOURCES} mac_utils.cpp)
-  set(HEADERS ${HEADERS} mac_utils.h)
 endif(APPLE)
 
 if(CMAKE_HOST_WIN32)
@@ -111,16 +65,8 @@ if(CMAKE_HOST_UNIX)
     set(SOURCES ${SOURCES} logbacktrace_unix.cpp)
 endif(CMAKE_HOST_UNIX)
 
-include_directories(${CMAKE_CURRENT_BINARY_DIR} ${CMAKE_CURRENT_SOURCE_DIR} ${QUASSEL_QT_INCLUDES})  # for version.inc and version.gen
-
-if(NOT WITH_QT5)
-  qt4_wrap_cpp(MOC ${MOC_HDRS})
-endif(NOT WITH_QT5)
-
-set_directory_properties(PROPERTIES ADDITIONAL_MAKE_CLEAN_FILES version.gen)
-
-add_library(mod_common STATIC ${SOURCES} ${HEADERS} ${MOC})
-set_target_properties(mod_common PROPERTIES COMPILE_FLAGS "${QUASSEL_QT_COMPILEFLAGS}")
+add_library(mod_common STATIC ${SOURCES})
+qt_use_modules(mod_common Core Network)
 
 if(APPLE)
   target_link_libraries(mod_common "-framework CoreServices" "-framework CoreFoundation")