common: Add ExpressionMatchTests unit tests
[quassel.git] / src / common / CMakeLists.txt
index 66416c3..4274cf4 100644 (file)
@@ -10,9 +10,14 @@ set(SOURCES
     bufferviewconfig.cpp
     bufferviewmanager.cpp
     compressor.cpp
+    coreinfo.cpp
     ctcpevent.cpp
+    dccconfig.cpp
     event.cpp
     eventmanager.cpp
+    expressionmatch.cpp
+    expressionmatchtests.cpp
+    highlightrulemanager.cpp
     identity.cpp
     ignorelistmanager.cpp
     internalpeer.cpp
@@ -21,6 +26,7 @@ set(SOURCES
     irclisthelper.cpp
     ircuser.cpp
     logger.cpp
+    logmessage.cpp
     message.cpp
     messageevent.cpp
     network.cpp
@@ -36,13 +42,15 @@ set(SOURCES
     syncableobject.cpp
     transfer.cpp
     transfermanager.cpp
+    types.cpp
     util.cpp
 
+    serializers/serializers.cpp
+
     protocols/datastream/datastreampeer.cpp
     protocols/legacy/legacypeer.cpp
 
     # needed for automoc
-    coreinfo.h
     irccap.h
     protocol.h
 )
@@ -74,7 +82,7 @@ endif()
 
 if (APPLE)
     set(SOURCES ${SOURCES} mac_utils.cpp)
-endif(APPLE)
+endif()
 
 if (WIN32)
     set(SOURCES ${SOURCES} logbacktrace_win.cpp)
@@ -93,7 +101,7 @@ qt_use_modules(mod_common Core Network)
 
 if (APPLE)
     target_link_libraries(mod_common "-framework CoreServices" "-framework CoreFoundation")
-endif(APPLE)
+endif()
 
 target_link_libraries(mod_common ${CMAKE_DL_LIBS} ${EXECINFO_LIBRARIES})