Implement IRCv3 tag parsing and sending
[quassel.git] / src / common / CMakeLists.txt
index f5bb920..417e5ff 100644 (file)
@@ -1,4 +1,4 @@
-quassel_add_module(Common)
+quassel_add_module(Common EXPORT)
 
 target_sources(${TARGET} PRIVATE
     abstractsignalwatcher.h
 
 target_sources(${TARGET} PRIVATE
     abstractsignalwatcher.h
@@ -17,7 +17,7 @@ target_sources(${TARGET} PRIVATE
     event.cpp
     eventmanager.cpp
     expressionmatch.cpp
     event.cpp
     eventmanager.cpp
     expressionmatch.cpp
-    # expressionmatchtests.cpp
+    funchelpers.h
     highlightrulemanager.cpp
     identity.cpp
     ignorelistmanager.cpp
     highlightrulemanager.cpp
     identity.cpp
     ignorelistmanager.cpp
@@ -25,9 +25,11 @@ target_sources(${TARGET} PRIVATE
     ircchannel.cpp
     ircevent.cpp
     irclisthelper.cpp
     ircchannel.cpp
     ircevent.cpp
     irclisthelper.cpp
+    ircdecoder.cpp
+    ircencoder.cpp
+    irctag.cpp
     ircuser.cpp
     logger.cpp
     ircuser.cpp
     logger.cpp
-    logmessage.cpp
     message.cpp
     messageevent.cpp
     network.cpp
     message.cpp
     messageevent.cpp
     network.cpp
@@ -63,11 +65,16 @@ target_include_directories(${TARGET} PRIVATE ${CMAKE_BINARY_DIR})
 
 target_link_libraries(${TARGET} PUBLIC
     ${CMAKE_DL_LIBS}
 
 target_link_libraries(${TARGET} PUBLIC
     ${CMAKE_DL_LIBS}
+    Boost::boost
     Qt5::Core
     Qt5::Network
     ZLIB::ZLIB
 )
 
     Qt5::Core
     Qt5::Network
     ZLIB::ZLIB
 )
 
+if (EMBED_DATA)
+    set_property(SOURCE quassel.cpp APPEND PROPERTY COMPILE_DEFINITIONS EMBED_DATA)
+endif()
+
 if (HAVE_SYSLOG)
     target_compile_definitions(${TARGET} PRIVATE -DHAVE_SYSLOG)
 endif()
 if (HAVE_SYSLOG)
     target_compile_definitions(${TARGET} PRIVATE -DHAVE_SYSLOG)
 endif()