Implement IRCv3 tag parsing and sending
[quassel.git] / src / common / CMakeLists.txt
index e7d7264..417e5ff 100644 (file)
@@ -25,9 +25,11 @@ target_sources(${TARGET} PRIVATE
     ircchannel.cpp
     ircevent.cpp
     irclisthelper.cpp
+    ircdecoder.cpp
+    ircencoder.cpp
+    irctag.cpp
     ircuser.cpp
     logger.cpp
-    logmessage.cpp
     message.cpp
     messageevent.cpp
     network.cpp
@@ -63,6 +65,7 @@ target_include_directories(${TARGET} PRIVATE ${CMAKE_BINARY_DIR})
 
 target_link_libraries(${TARGET} PUBLIC
     ${CMAKE_DL_LIBS}
+    Boost::boost
     Qt5::Core
     Qt5::Network
     ZLIB::ZLIB