Finally sanitizificat0red the mess and #ifdef hell with main.cpp, Global:: and friends
[quassel.git] / src / common / CMakeLists.txt
index 765d7ba..3dfd92a 100644 (file)
@@ -5,25 +5,27 @@ set(QT_USE_QTNETWORK 1)
 include(${QT_USE_FILE})
 
 set(SOURCES
+    aliasmanager.cpp
     backlogmanager.cpp
     bufferinfo.cpp
     buffersyncer.cpp
     bufferviewconfig.cpp
     bufferviewmanager.cpp
-    global.cpp
+    cliparser.cpp
     identity.cpp
+    ircchannel.cpp
+    ircuser.cpp
     logger.cpp
     message.cpp
+    network.cpp
+    quassel.cpp
     settings.cpp
     signalproxy.cpp
     syncableobject.cpp
-    util.cpp
-    network.cpp
-    ircuser.cpp
-    ircchannel.cpp
-    cliparser.cpp)
+    util.cpp)
 
 set(MOC_HDRS
+    aliasmanager.h
     backlogmanager.h
     buffersyncer.h
     bufferviewconfig.h
@@ -33,19 +35,18 @@ set(MOC_HDRS
     ircchannel.h
     irclisthelper.h
     ircuser.h
-    logger.h
     network.h
+    settings.h
     signalproxy.h
     syncableobject.h)
 
 set(HEADERS ${MOC_HDRS}
     bufferinfo.h
-    global.h
+    cliparser.h
+    logger.h
     message.h
-    settings.h
     types.h
-    util.h
-    cliparser.h)
+    util.h)
 
 qt4_wrap_cpp(MOC ${MOC_HDRS})