Make SSL and syslog support non-configurable
[quassel.git] / src / common / CMakeLists.txt
index b2f9c71..36218f4 100644 (file)
@@ -57,6 +57,10 @@ else()
     set(SOURCES ${SOURCES} ../../3rdparty/miniz/miniz.c)
 endif()
 
+if (HAVE_SYSLOG)
+    add_definitions(-DHAVE_SYSLOG)
+endif()
+
 if(APPLE)
   set(SOURCES ${SOURCES} mac_utils.cpp)
 endif(APPLE)