fixed enabled inline assembler for backtrace on windows
[quassel.git] / src / common / CMakeLists.txt
index 7c883a9..30eed02 100644 (file)
@@ -7,13 +7,16 @@ include(${QT_USE_FILE})
 set(SOURCES
     aliasmanager.cpp
     backlogmanager.cpp
+    basichandler.cpp
     bufferinfo.cpp
     buffersyncer.cpp
     bufferviewconfig.cpp
     bufferviewmanager.cpp
     cliparser.cpp
     identity.cpp
+    ignorelistmanager.cpp
     ircchannel.cpp
+    irclisthelper.cpp
     ircuser.cpp
     logger.cpp
     message.cpp
@@ -35,11 +38,13 @@ endif(CMAKE_HOST_UNIX)
 set(MOC_HDRS
     aliasmanager.h
     backlogmanager.h
+    basichandler.h
     buffersyncer.h
     bufferviewconfig.h
     bufferviewmanager.h
     coreinfo.h
     identity.h
+    ignorelistmanager.h
     ircchannel.h
     irclisthelper.h
     ircuser.h
@@ -69,6 +74,14 @@ include_directories(${CMAKE_CURRENT_BINARY_DIR} ${CMAKE_SOURCE_DIR})  # for vers
 set_directory_properties(PROPERTIES ADDITIONAL_MAKE_CLEAN_FILES version.gen)
 
 add_library(mod_common STATIC ${SOURCES} ${MOC})
+
 if(APPLE)
   target_link_libraries(mod_common "-framework CoreServices" "-framework CoreFoundation")
-endif(APPLE)
\ No newline at end of file
+endif(APPLE)
+
+if(CMAKE_HOST_SYSTEM_NAME STREQUAL "Linux")
+  find_library(libdl dl)
+  if(NOT libdl MATCHES "NOTFOUND")
+    target_link_libraries(mod_common ${libdl})
+  endif(NOT libdl MATCHES "NOTFOUND")
+endif(CMAKE_HOST_SYSTEM_NAME STREQUAL "Linux")