Consolidate protocol messages in one namespace
[quassel.git] / src / common / CMakeLists.txt
index 9c273e6..3043bb1 100644 (file)
@@ -17,6 +17,7 @@ set(SOURCES
     eventmanager.cpp
     identity.cpp
     ignorelistmanager.cpp
+    internalconnection.cpp
     ircchannel.cpp
     ircevent.cpp
     irclisthelper.cpp
@@ -28,10 +29,14 @@ set(SOURCES
     networkconfig.cpp
     networkevent.cpp
     quassel.cpp
+    remoteconnection.cpp
     settings.cpp
     signalproxy.cpp
     syncableobject.cpp
-    util.cpp)
+    util.cpp
+
+    protocols/legacy/legacyconnection.cpp
+)
 
 set(MOC_HDRS
     aliasmanager.h
@@ -44,14 +49,19 @@ set(MOC_HDRS
     eventmanager.h
     identity.h
     ignorelistmanager.h
+    internalconnection.h
     ircchannel.h
     irclisthelper.h
     ircuser.h
     network.h
     networkconfig.h
+    remoteconnection.h
     settings.h
     signalproxy.h
-    syncableobject.h)
+    syncableobject.h
+
+    protocols/legacy/legacyconnection.h
+)
 
 set(HEADERS ${MOC_HDRS}
     abstractcliparser.h
@@ -60,10 +70,11 @@ set(HEADERS ${MOC_HDRS}
     ctcpevent.h
     event.h
     ircevent.h
-    networkevent.h
     messageevent.h
+    networkevent.h
     logger.h
     message.h
+    protocol.h
     types.h
     util.h)
 
@@ -87,7 +98,7 @@ endif(NOT WITH_QT5)
 
 set_directory_properties(PROPERTIES ADDITIONAL_MAKE_CLEAN_FILES version.gen)
 
-add_library(mod_common STATIC ${SOURCES} ${MOC})
+add_library(mod_common STATIC ${SOURCES} ${HEADERS} ${MOC})
 set_target_properties(mod_common PROPERTIES COMPILE_FLAGS "${QUASSEL_QT_COMPILEFLAGS}")
 
 if(APPLE)