Happy New Year!
[quassel.git] / src / common / CMakeLists.txt
index b2f9c71..23e5601 100644 (file)
@@ -29,6 +29,7 @@ set(SOURCES
     networkevent.cpp
     peer.cpp
     peerfactory.cpp
+    presetnetworks.cpp
     quassel.cpp
     remotepeer.cpp
     settings.cpp
@@ -57,6 +58,10 @@ else()
     set(SOURCES ${SOURCES} ../../3rdparty/miniz/miniz.c)
 endif()
 
+if (HAVE_SYSLOG)
+    add_definitions(-DHAVE_SYSLOG)
+endif()
+
 if(APPLE)
   set(SOURCES ${SOURCES} mac_utils.cpp)
 endif(APPLE)
@@ -71,6 +76,8 @@ else()
     set(SOURCES ${SOURCES} logbacktrace_unix.cpp)
 endif()
 
+qt_add_resources(SOURCES ${COMMON_RCS})
+
 add_library(mod_common STATIC ${SOURCES})
 qt_use_modules(mod_common Core Network)
 
@@ -79,3 +86,7 @@ if(APPLE)
 endif(APPLE)
 
 target_link_libraries(mod_common ${CMAKE_DL_LIBS} ${EXECINFO_LIBRARIES} ${ZLIB_LIBRARIES})
+
+# This is needed so translations are generated before trying to build the qrc.
+# Should probably find a nicer solution with proper dependencies between the involved files, though...
+add_dependencies(mod_common po)