cmake: Link resources statically, and init locally
[quassel.git] / src / common / CMakeLists.txt
index ebc626f..2069a35 100644 (file)
@@ -56,8 +56,6 @@ target_sources(${TARGET} PRIVATE
     # needed for automoc
     irccap.h
     protocol.h
-
-    ${COMMON_RCS}
 )
 
 # Needed for finding the generated version.h
@@ -70,6 +68,10 @@ target_link_libraries(${TARGET} PUBLIC
     ZLIB::ZLIB
 )
 
+if (EMBED_DATA)
+    set_property(SOURCE quassel.cpp APPEND PROPERTY COMPILE_DEFINITIONS EMBED_DATA)
+endif()
+
 if (HAVE_SYSLOG)
     target_compile_definitions(${TARGET} PRIVATE -DHAVE_SYSLOG)
 endif()
@@ -91,6 +93,4 @@ if (APPLE)
     target_link_libraries(${TARGET} PUBLIC "-framework CoreServices" "-framework CoreFoundation")
 endif()
 
-# This is needed so translations are generated before trying to build the qrc.
-# Should probably find a nicer solution with proper dependencies between the involved files, though...
-add_dependencies(${TARGET} po)
+target_link_if_exists(${TARGET} PUBLIC Quassel::Resource::I18n)