Implement core-side highlights
[quassel.git] / src / common / CMakeLists.txt
index 90ccb5f..1deac52 100644 (file)
@@ -11,8 +11,10 @@ set(SOURCES
     bufferviewmanager.cpp
     compressor.cpp
     ctcpevent.cpp
+    dccconfig.cpp
     event.cpp
     eventmanager.cpp
+    highlightrulemanager.cpp
     identity.cpp
     ignorelistmanager.cpp
     internalpeer.cpp
@@ -43,6 +45,8 @@ set(SOURCES
 
     # needed for automoc
     coreinfo.h
+    irccap.h
+    protocol.h
 )
 
 if (USE_QT5)
@@ -62,13 +66,17 @@ else()
     set(SOURCES ${SOURCES} ../../3rdparty/miniz/miniz.c)
 endif()
 
+if (USE_QT4)
+    set(SOURCES ${SOURCES} ../../3rdparty/sha512/sha512.c)
+endif()
+
 if (HAVE_SYSLOG)
     add_definitions(-DHAVE_SYSLOG)
 endif()
 
 if (APPLE)
     set(SOURCES ${SOURCES} mac_utils.cpp)
-endif(APPLE)
+endif()
 
 if (WIN32)
     set(SOURCES ${SOURCES} logbacktrace_win.cpp)
@@ -87,9 +95,13 @@ qt_use_modules(mod_common Core Network)
 
 if (APPLE)
     target_link_libraries(mod_common "-framework CoreServices" "-framework CoreFoundation")
-endif(APPLE)
+endif()
+
+target_link_libraries(mod_common ${CMAKE_DL_LIBS} ${EXECINFO_LIBRARIES})
 
-target_link_libraries(mod_common ${CMAKE_DL_LIBS} ${EXECINFO_LIBRARIES} ${ZLIB_LIBRARIES})
+if(ZLIB_FOUND)
+    target_link_libraries(mod_common ${ZLIB_LIBRARIES})
+endif()
 
 # This is needed so translations are generated before trying to build the qrc.
 # Should probably find a nicer solution with proper dependencies between the involved files, though...