cmake: Use official CMake config for QCA
[quassel.git] / src / common / CMakeLists.txt
index 36218f4..1b77daf 100644 (file)
@@ -1,6 +1,7 @@
 # Builds the common module
 
 set(SOURCES
+    abstractsignalwatcher.h
     aliasmanager.cpp
     authhandler.cpp
     backlogmanager.cpp
@@ -9,11 +10,15 @@ set(SOURCES
     buffersyncer.cpp
     bufferviewconfig.cpp
     bufferviewmanager.cpp
-    cliparser.cpp
     compressor.cpp
+    coreinfo.cpp
     ctcpevent.cpp
+    dccconfig.cpp
     event.cpp
     eventmanager.cpp
+    expressionmatch.cpp
+    # expressionmatchtests.cpp
+    highlightrulemanager.cpp
     identity.cpp
     ignorelistmanager.cpp
     internalpeer.cpp
@@ -22,64 +27,68 @@ set(SOURCES
     irclisthelper.cpp
     ircuser.cpp
     logger.cpp
+    logmessage.cpp
     message.cpp
     messageevent.cpp
     network.cpp
     networkconfig.cpp
     networkevent.cpp
+    nickhighlightmatcher.cpp
     peer.cpp
     peerfactory.cpp
+    presetnetworks.cpp
     quassel.cpp
     remotepeer.cpp
     settings.cpp
     signalproxy.cpp
+    singleton.h
     syncableobject.cpp
     transfer.cpp
     transfermanager.cpp
+    types.cpp
     util.cpp
 
+    serializers/serializers.cpp
+
     protocols/datastream/datastreampeer.cpp
     protocols/legacy/legacypeer.cpp
 
     # needed for automoc
-    coreinfo.h
+    irccap.h
+    protocol.h
 )
 
-
-if (QCA2_FOUND)
-    set(SOURCES ${SOURCES} keyevent.cpp)
+if (HAVE_SYSLOG)
+    add_definitions(-DHAVE_SYSLOG)
 endif()
 
-if (ZLIB_FOUND)
-    add_definitions(-DHAVE_ZLIB)
-    include_directories(${ZLIB_INCLUDE_DIRS})
-else()
-    set(SOURCES ${SOURCES} ../../3rdparty/miniz/miniz.c)
+if (APPLE)
+    set(SOURCES ${SOURCES} mac_utils.cpp)
 endif()
 
-if (HAVE_SYSLOG)
-    add_definitions(-DHAVE_SYSLOG)
-endif()
+qt5_add_resources(SOURCES ${COMMON_RCS})
 
-if(APPLE)
-  set(SOURCES ${SOURCES} mac_utils.cpp)
-endif(APPLE)
+add_library(mod_common STATIC ${SOURCES})
+qt5_use_modules(mod_common Core Network)
 
 if (WIN32)
-    set(SOURCES ${SOURCES} logbacktrace_win.cpp)
+    target_sources(mod_common PRIVATE logbacktrace_win.cpp windowssignalwatcher.cpp)
 else()
-    if (EXECINFO_FOUND)
-        add_definitions(-DHAVE_EXECINFO)
-        include_directories(${EXECINFO_INCLUDES})
+    if (Backtrace_FOUND)
+        configure_file(backtrace_config.h.in backtrace_config.h)
+        target_compile_definitions(mod_common PRIVATE -DHAVE_BACKTRACE)
+        target_include_directories(mod_common PRIVATE ${Backtrace_INCLUDE_DIRS})
+        target_link_libraries(mod_common PRIVATE ${Backtrace_LIBRARIES})
     endif()
-    set(SOURCES ${SOURCES} logbacktrace_unix.cpp)
+    target_sources(mod_common PRIVATE logbacktrace_unix.cpp posixsignalwatcher.cpp)
 endif()
 
-add_library(mod_common STATIC ${SOURCES})
-qt_use_modules(mod_common Core Network)
+if (APPLE)
+    target_link_libraries(mod_common "-framework CoreServices" "-framework CoreFoundation")
+endif()
 
-if(APPLE)
-  target_link_libraries(mod_common "-framework CoreServices" "-framework CoreFoundation")
-endif(APPLE)
+target_link_libraries(mod_common ${CMAKE_DL_LIBS} ZLIB::ZLIB)
 
-target_link_libraries(mod_common ${CMAKE_DL_LIBS} ${EXECINFO_LIBRARIES} ${ZLIB_LIBRARIES})
+# This is needed so translations are generated before trying to build the qrc.
+# Should probably find a nicer solution with proper dependencies between the involved files, though...
+add_dependencies(mod_common po)