Indicate whether a key is set for the buffer.
[quassel.git] / src / common / CMakeLists.txt
index fe1d4f9..18e6fcf 100644 (file)
@@ -28,6 +28,7 @@ set(SOURCES
     network.cpp
     networkconfig.cpp
     networkevent.cpp
+    peer.cpp
     quassel.cpp
     remotepeer.cpp
     settings.cpp
@@ -55,6 +56,7 @@ set(MOC_HDRS
     ircuser.h
     network.h
     networkconfig.h
+    peer.h
     remotepeer.h
     settings.h
     signalproxy.h
@@ -78,6 +80,11 @@ set(HEADERS ${MOC_HDRS}
     types.h
     util.h)
 
+if (HAVE_QCA2)
+    set(SOURCES ${SOURCES} keyevent.cpp)
+    set(HEADERS ${HEADERS} keyevent.h)
+endif(HAVE_QCA2)
+
 if(APPLE)
   set(SOURCES ${SOURCES} mac_utils.cpp)
   set(HEADERS ${HEADERS} mac_utils.h)