use CMAKE_DL_LIBS
[quassel.git] / src / common / CMakeLists.txt
index c5da750..0e3e2a1 100644 (file)
@@ -12,15 +12,18 @@ set(SOURCES
     bufferviewconfig.cpp
     bufferviewmanager.cpp
     cliparser.cpp
+    ctcpevent.cpp
     event.cpp
     eventmanager.cpp
     identity.cpp
     ignorelistmanager.cpp
     ircchannel.cpp
+    ircevent.cpp
     irclisthelper.cpp
     ircuser.cpp
     logger.cpp
     message.cpp
+    messageevent.cpp
     network.cpp
     networkconfig.cpp
     networkevent.cpp
@@ -54,8 +57,11 @@ set(HEADERS ${MOC_HDRS}
     abstractcliparser.h
     bufferinfo.h
     cliparser.h
+    ctcpevent.h
     event.h
+    ircevent.h
     networkevent.h
+    messageevent.h
     logger.h
     message.h
     types.h
@@ -84,9 +90,4 @@ if(APPLE)
   target_link_libraries(mod_common "-framework CoreServices" "-framework CoreFoundation")
 endif(APPLE)
 
-if(CMAKE_HOST_SYSTEM_NAME STREQUAL "Linux")
-  find_library(libdl dl)
-  if(NOT libdl MATCHES "NOTFOUND")
-    target_link_libraries(mod_common ${libdl})
-  endif(NOT libdl MATCHES "NOTFOUND")
-endif(CMAKE_HOST_SYSTEM_NAME STREQUAL "Linux")
+target_link_libraries(mod_common ${CMAKE_DL_LIBS})