Don't make EventType::KeyEvent depend on HAVE_QCA2
[quassel.git] / src / common / CMakeLists.txt
index 8690625..0191c81 100644 (file)
@@ -1,7 +1,5 @@
 # Builds the common module
 
-setup_qt_variables(Core Network)
-
 set(SOURCES
     aliasmanager.cpp
     authhandler.cpp
@@ -52,25 +50,22 @@ if (HAVE_QCA2)
     set(SOURCES ${SOURCES} keyevent.cpp)
 endif(HAVE_QCA2)
 
-if(NOT HAVE_ZLIB)
+if (NOT ZLIB_FOUND)
     set(SOURCES ${SOURCES} ../../3rdparty/miniz/miniz.c)
-endif(NOT HAVE_ZLIB)
+endif()
 
 if(APPLE)
   set(SOURCES ${SOURCES} mac_utils.cpp)
 endif(APPLE)
 
-if(CMAKE_HOST_WIN32)
+if (WIN32)
     set(SOURCES ${SOURCES} logbacktrace_win.cpp)
-endif(CMAKE_HOST_WIN32)
-if(CMAKE_HOST_UNIX)
+elseif (UNIX)
     set(SOURCES ${SOURCES} logbacktrace_unix.cpp)
-endif(CMAKE_HOST_UNIX)
-
-include_directories(${CMAKE_CURRENT_BINARY_DIR} ${CMAKE_CURRENT_SOURCE_DIR} ${QUASSEL_QT_INCLUDES})  # for version.inc and version.gen
+endif()
 
 add_library(mod_common STATIC ${SOURCES})
-set_target_properties(mod_common PROPERTIES COMPILE_FLAGS "${QUASSEL_QT_COMPILEFLAGS}")
+qt_use_modules(mod_common Core Network)
 
 if(APPLE)
   target_link_libraries(mod_common "-framework CoreServices" "-framework CoreFoundation")