new internal hot buffers list
[quassel.git] / src / client / CMakeLists.txt
index 159b4f1..f9a60f2 100644 (file)
@@ -1,7 +1,70 @@
-SET(client_SRCS buffer.cpp buffertreemodel.cpp client.cpp clientproxy.cpp clientsettings.cpp treemodel.cpp)
-SET(client_HDRS )
-SET(client_MOCS buffer.h buffertreemodel.h client.h clientproxy.h clientsettings.h treemodel.h)
+# Builds the client module
 
-QT4_WRAP_CPP(_MOC ${client_MOCS})
-ADD_LIBRARY(client ${client_SRCS} ${_MOC})
-TARGET_LINK_LIBRARIES(client common)
\ No newline at end of file
+# We still have some minor deps to QtUi: QItemSelectionModel
+# set(QT_DONT_USE_QTGUI 1)
+set(QT_USE_QTNETWORK 1)
+set(QT_USE_QTDBUS 1)
+include(${QT_USE_FILE})
+
+set(SOURCES
+    abstractmessageprocessor.cpp
+    abstractui.cpp
+    backlogrequester.cpp
+    bufferhotlistfilter.cpp
+    buffermodel.cpp
+    buffersettings.cpp
+    bufferviewoverlay.cpp
+    client.cpp
+    clientaliasmanager.cpp
+    clientbacklogmanager.cpp
+    clientbufferviewconfig.cpp
+    clientbufferviewmanager.cpp
+    clientidentity.cpp
+    clientirclisthelper.cpp
+    clientsettings.cpp
+    clientsyncer.cpp
+    clientuserinputhandler.cpp
+    execwrapper.cpp
+    irclistmodel.cpp
+    messagefilter.cpp
+    messagemodel.cpp
+    networkmodel.cpp
+    selectionmodelsynchronizer.cpp
+    treemodel.cpp)
+
+set(MOC_HDRS
+    abstractmessageprocessor.h
+    abstractui.h
+    bufferhotlistfilter.h
+    buffermodel.h
+    bufferviewoverlay.h
+    client.h
+    clientaliasmanager.h
+    clientbacklogmanager.h
+    clientbufferviewconfig.h
+    clientbufferviewmanager.h
+    clientcoreinfo.h
+    clientidentity.h
+    clientirclisthelper.h
+    clientuserinputhandler.h
+    clientsyncer.h
+    execwrapper.h
+    irclistmodel.h
+    messagefilter.h
+    messagemodel.h
+    networkmodel.h
+    selectionmodelsynchronizer.h
+    treemodel.h)
+
+set(HEADERS
+    backlogsettings.h
+    backlogrequester.h
+    buffersettings.h
+    clientsettings.h)
+
+qt4_wrap_cpp(MOC ${MOC_HDRS})
+
+include_directories(${CMAKE_SOURCE_DIR}/src/common)
+
+add_library(mod_client STATIC ${SOURCES} ${MOC} ${HEADERS})
+add_dependencies(mod_client mod_common)