Initialize new buffers in the UI with their activity
[quassel.git] / src / client / CMakeLists.txt
index c149f25..f0733f0 100644 (file)
@@ -1,20 +1,8 @@
 # Builds the client module
 
-# In Qt4, we still have some minor deps to QtUi: QItemSelectionModel, QSortFilterProxyModel
+# In Qt4, we still have some minor deps to QtGui: QItemSelectionModel, QSortFilterProxyModel
 # Still in Qt5: QAbstractItemView in BufferModel
 
-set(_modules )
-
-if(WITH_QT5)
-  list(APPEND _modules Widgets)
-endif(WITH_QT5)
-
-if(HAVE_DBUS)
-  list(APPEND _modules DBus)
-endif(HAVE_DBUS)
-
-setup_qt_variables(Gui Network ${_modules})
-
 set(SOURCES
     abstractmessageprocessor.cpp
     backlogrequester.cpp
@@ -43,6 +31,7 @@ set(SOURCES
     messagemodel.cpp
     networkmodel.cpp
     selectionmodelsynchronizer.cpp
+    transfermodel.cpp
     treemodel.cpp
 
     # needed for automoc
@@ -50,9 +39,13 @@ set(SOURCES
     clientcoreinfo.h
 )
 
-include_directories(${CMAKE_SOURCE_DIR}/src/common ${QUASSEL_QT_INCLUDES})
+if (USE_QT5)
+    list(APPEND qt_modules Widgets)
+endif()
+
+qt_add_resources(SOURCES ${CLIENT_RCS})
 
 add_library(mod_client STATIC ${SOURCES})
-add_dependencies(mod_client mod_common)
+qt_use_modules(mod_client Network Core Gui ${qt_modules})
 
-set_target_properties(mod_client PROPERTIES COMPILE_FLAGS "${QUASSEL_QT_COMPILEFLAGS}")
+target_link_libraries(mod_client mod_common)