Initialize new buffers in the UI with their activity
[quassel.git] / src / client / CMakeLists.txt
index bc74ecc..f0733f0 100644 (file)
@@ -31,6 +31,7 @@ set(SOURCES
     messagemodel.cpp
     networkmodel.cpp
     selectionmodelsynchronizer.cpp
+    transfermodel.cpp
     treemodel.cpp
 
     # needed for automoc
@@ -38,20 +39,13 @@ set(SOURCES
     clientcoreinfo.h
 )
 
-if (KDE4_FOUND)
-    include_directories(${KDE4_INCLUDES})
-    add_definitions(-DHAVE_KDE ${KDE4_DEFINITIONS})
-endif()
-
 if (USE_QT5)
     list(APPEND qt_modules Widgets)
 endif()
 
+qt_add_resources(SOURCES ${CLIENT_RCS})
+
 add_library(mod_client STATIC ${SOURCES})
 qt_use_modules(mod_client Network Core Gui ${qt_modules})
 
-if (KDE4_FOUND)
-    target_link_libraries(mod_client ${KDE4_SOLID_LIBS})
-endif()
-
-add_dependencies(mod_client mod_common)
+target_link_libraries(mod_client mod_common)