Initialize new buffers in the UI with their activity
[quassel.git] / src / client / CMakeLists.txt
index 935ba86..f0733f0 100644 (file)
@@ -31,6 +31,7 @@ set(SOURCES
     messagemodel.cpp
     networkmodel.cpp
     selectionmodelsynchronizer.cpp
+    transfermodel.cpp
     treemodel.cpp
 
     # needed for automoc
@@ -42,10 +43,9 @@ if (USE_QT5)
     list(APPEND qt_modules Widgets)
 endif()
 
-if (HAVE_DBUS)
-    list(APPEND qt_modules DBus)
-endif()
+qt_add_resources(SOURCES ${CLIENT_RCS})
 
 add_library(mod_client STATIC ${SOURCES})
 qt_use_modules(mod_client Network Core Gui ${qt_modules})
-add_dependencies(mod_client mod_common)
+
+target_link_libraries(mod_client mod_common)