Finalizing changes to the identities interface -> breaking protocol
[quassel.git] / src / client / CMakeLists.txt
index f6651ae..f000508 100644 (file)
@@ -8,11 +8,12 @@ include(${QT_USE_FILE})
 
 set(SOURCES
     abstractmessageprocessor.cpp
-    buffer.cpp
+    backlogrequester.cpp
     buffermodel.cpp
     buffersettings.cpp
     client.cpp
     clientbacklogmanager.cpp
+    clientidentity.cpp
     clientirclisthelper.cpp
     clientsettings.cpp
     clientsyncer.cpp
@@ -27,11 +28,11 @@ set(SOURCES
 
 set(MOC_HDRS
     abstractmessageprocessor.h
-    buffer.h
     buffermodel.h
     client.h
     clientbacklogmanager.h
     clientcoreinfo.h
+    clientidentity.h
     clientirclisthelper.h
     clientsyncer.h
     irclistmodel.h
@@ -44,6 +45,8 @@ set(MOC_HDRS
     treemodel.h)
 
 set(HEADERS
+    backlogsettings.h
+    backlogrequester.h
     buffersettings.h
     clientsettings.h)