Fix includes
[quassel.git] / src / client / CMakeLists.txt
index f9a60f2..c851907 100644 (file)
@@ -8,9 +8,7 @@ include(${QT_USE_FILE})
 
 set(SOURCES
     abstractmessageprocessor.cpp
-    abstractui.cpp
     backlogrequester.cpp
-    bufferhotlistfilter.cpp
     buffermodel.cpp
     buffersettings.cpp
     bufferviewoverlay.cpp
@@ -20,10 +18,13 @@ set(SOURCES
     clientbufferviewconfig.cpp
     clientbufferviewmanager.cpp
     clientidentity.cpp
+    clientignorelistmanager.cpp
     clientirclisthelper.cpp
     clientsettings.cpp
-    clientsyncer.cpp
     clientuserinputhandler.cpp
+    coreaccount.cpp
+    coreaccountmodel.cpp
+    coreconnection.cpp
     execwrapper.cpp
     irclistmodel.cpp
     messagefilter.cpp
@@ -35,7 +36,6 @@ set(SOURCES
 set(MOC_HDRS
     abstractmessageprocessor.h
     abstractui.h
-    bufferhotlistfilter.h
     buffermodel.h
     bufferviewoverlay.h
     client.h
@@ -45,9 +45,11 @@ set(MOC_HDRS
     clientbufferviewmanager.h
     clientcoreinfo.h
     clientidentity.h
+    clientignorelistmanager.h
     clientirclisthelper.h
     clientuserinputhandler.h
-    clientsyncer.h
+    coreaccountmodel.h
+    coreconnection.h
     execwrapper.h
     irclistmodel.h
     messagefilter.h
@@ -60,7 +62,9 @@ set(HEADERS
     backlogsettings.h
     backlogrequester.h
     buffersettings.h
-    clientsettings.h)
+    clientsettings.h
+    coreaccount.h
+   )
 
 qt4_wrap_cpp(MOC ${MOC_HDRS})