Search the web with selected text.
[quassel.git] / src / client / CMakeLists.txt
index 67ca7f8..c7b3ee3 100644 (file)
@@ -2,11 +2,18 @@
 
 # In Qt4, we still have some minor deps to QtUi: QItemSelectionModel, QSortFilterProxyModel
 # Still in Qt5: QAbstractItemView in BufferModel
-if(NOT WITH_QT5)
-  setup_qt_variables(Gui Network DBus)
-else(NOT WITH_QT5)
-  setup_qt_variables(Widgets Network DBus)
-endif(NOT WITH_QT5)
+
+set(_modules )
+
+if(WITH_QT5)
+  list(APPEND _modules Widgets)
+endif(WITH_QT5)
+
+if(HAVE_DBUS)
+  list(APPEND _modules DBus)
+endif(HAVE_DBUS)
+
+setup_qt_variables(Gui Network ${_modules})
 
 set(SOURCES
     abstractmessageprocessor.cpp
@@ -17,6 +24,7 @@ set(SOURCES
     bufferviewoverlay.cpp
     client.cpp
     clientaliasmanager.cpp
+    clientauthhandler.cpp
     clientbacklogmanager.cpp
     clientbufferviewconfig.cpp
     clientbufferviewmanager.cpp
@@ -25,6 +33,8 @@ set(SOURCES
     clientignorelistmanager.cpp
     clientirclisthelper.cpp
     clientsettings.cpp
+    clienttransfer.cpp
+    clienttransfermanager.cpp
     clientuserinputhandler.cpp
     coreaccount.cpp
     coreaccountmodel.cpp
@@ -44,6 +54,7 @@ set(MOC_HDRS
     bufferviewoverlay.h
     client.h
     clientaliasmanager.h
+    clientauthhandler.h
     clientbacklogmanager.h
     clientbufferviewconfig.h
     clientbufferviewmanager.h
@@ -51,6 +62,8 @@ set(MOC_HDRS
     clientidentity.h
     clientignorelistmanager.h
     clientirclisthelper.h
+    clienttransfer.h
+    clienttransfermanager.h
     clientuserinputhandler.h
     coreaccountmodel.h
     coreconnection.h