Enable automoc
[quassel.git] / src / client / CMakeLists.txt
index d4a2459..c149f25 100644 (file)
@@ -1,52 +1,58 @@
 # Builds the client module
 
-# We still have some minor deps to QtUi: QItemSelectionModel
-# set(QT_DONT_USE_QTGUI 1)
-set(QT_USE_QTNETWORK 1)
-set(QT_USE_QTDBUS 1)
-include(${QT_USE_FILE})
+# In Qt4, we still have some minor deps to QtUi: QItemSelectionModel, QSortFilterProxyModel
+# Still in Qt5: QAbstractItemView in BufferModel
+
+set(_modules )
+
+if(WITH_QT5)
+  list(APPEND _modules Widgets)
+endif(WITH_QT5)
+
+if(HAVE_DBUS)
+  list(APPEND _modules DBus)
+endif(HAVE_DBUS)
+
+setup_qt_variables(Gui Network ${_modules})
 
 set(SOURCES
-    buffer.cpp
+    abstractmessageprocessor.cpp
+    backlogrequester.cpp
     buffermodel.cpp
     buffersettings.cpp
+    bufferviewoverlay.cpp
     client.cpp
+    clientaliasmanager.cpp
+    clientauthhandler.cpp
     clientbacklogmanager.cpp
+    clientbufferviewconfig.cpp
+    clientbufferviewmanager.cpp
+    clientidentity.cpp
+    clientignorelistmanager.cpp
     clientirclisthelper.cpp
     clientsettings.cpp
-    clientsyncer.cpp
+    clienttransfer.cpp
+    clienttransfermanager.cpp
+    clientuserinputhandler.cpp
+    coreaccount.cpp
+    coreaccountmodel.cpp
+    coreconnection.cpp
+    execwrapper.cpp
     irclistmodel.cpp
     messagefilter.cpp
     messagemodel.cpp
-    mappedselectionmodel.cpp
     networkmodel.cpp
     selectionmodelsynchronizer.cpp
-    treemodel.cpp)
+    treemodel.cpp
 
-set(MOC_HDRS
-    buffer.h
-    buffermodel.h
-    client.h
-    clientbacklogmanager.h
+    # needed for automoc
+    abstractui.h
     clientcoreinfo.h
-    clientirclisthelper.h
-    clientsyncer.h
-    irclistmodel.h
-    messagefilter.h
-    messagemodel.h
-    networkmodel.h
-    mappedselectionmodel.h
-    quasselui.h
-    selectionmodelsynchronizer.h
-    treemodel.h)
-
-set(HEADERS
-    buffersettings.h
-    clientsettings.h)
-
-qt4_wrap_cpp(MOC ${MOC_HDRS})
-
-include_directories(${CMAKE_SOURCE_DIR}/src/common)
-
-add_library(mod_client STATIC ${SOURCES} ${MOC} ${HEADERS})
+)
+
+include_directories(${CMAKE_SOURCE_DIR}/src/common ${QUASSEL_QT_INCLUDES})
+
+add_library(mod_client STATIC ${SOURCES})
 add_dependencies(mod_client mod_common)
+
+set_target_properties(mod_client PROPERTIES COMPILE_FLAGS "${QUASSEL_QT_COMPILEFLAGS}")