Enable automoc
[quassel.git] / src / client / CMakeLists.txt
index 3ad8f7d..c149f25 100644 (file)
@@ -1,8 +1,58 @@
-SET(client_SRCS buffer.cpp buffertreemodel.cpp client.cpp clientsettings.cpp treemodel.cpp)
-SET(client_HDRS )
-SET(client_MOCS buffer.h buffertreemodel.h client.h clientsettings.h quasselui.h treemodel.h)
+# Builds the client module
 
-QT4_WRAP_CPP(_MOC ${client_MOCS})
+# In Qt4, we still have some minor deps to QtUi: QItemSelectionModel, QSortFilterProxyModel
+# Still in Qt5: QAbstractItemView in BufferModel
 
-ADD_LIBRARY(client ${client_SRCS} ${_MOC})
-TARGET_LINK_LIBRARIES(client common)
\ No newline at end of file
+set(_modules )
+
+if(WITH_QT5)
+  list(APPEND _modules Widgets)
+endif(WITH_QT5)
+
+if(HAVE_DBUS)
+  list(APPEND _modules DBus)
+endif(HAVE_DBUS)
+
+setup_qt_variables(Gui Network ${_modules})
+
+set(SOURCES
+    abstractmessageprocessor.cpp
+    backlogrequester.cpp
+    buffermodel.cpp
+    buffersettings.cpp
+    bufferviewoverlay.cpp
+    client.cpp
+    clientaliasmanager.cpp
+    clientauthhandler.cpp
+    clientbacklogmanager.cpp
+    clientbufferviewconfig.cpp
+    clientbufferviewmanager.cpp
+    clientidentity.cpp
+    clientignorelistmanager.cpp
+    clientirclisthelper.cpp
+    clientsettings.cpp
+    clienttransfer.cpp
+    clienttransfermanager.cpp
+    clientuserinputhandler.cpp
+    coreaccount.cpp
+    coreaccountmodel.cpp
+    coreconnection.cpp
+    execwrapper.cpp
+    irclistmodel.cpp
+    messagefilter.cpp
+    messagemodel.cpp
+    networkmodel.cpp
+    selectionmodelsynchronizer.cpp
+    treemodel.cpp
+
+    # needed for automoc
+    abstractui.h
+    clientcoreinfo.h
+)
+
+include_directories(${CMAKE_SOURCE_DIR}/src/common ${QUASSEL_QT_INCLUDES})
+
+add_library(mod_client STATIC ${SOURCES})
+add_dependencies(mod_client mod_common)
+
+set_target_properties(mod_client PROPERTIES COMPILE_FLAGS "${QUASSEL_QT_COMPILEFLAGS}")